BackupAssist Jobs nach Update nicht vorhanden
Problem:
Nach dem Update einer BackupAssist-Version kann es vereinzelt dazu kommen, dass die vorher angelegten Jobs nicht mehr in der Konsole angezeigt werden.
Ursache:
Ursache davon ist dann eine korrupte "CortexIT.BA.BackupJobs.JobService.config"-Datei im "\ProgramData\BackupAssistvX\Jobs"-Verzeichnis, die die Verlinkung zwischen vorhandenen Jobs und der BackupAssist Konsole nicht mehr herstellen kann.
Lösung:
Damit die Jobs wieder eingelesen werden können, muss entweder der vorherige "Jobs"-Ordner aus einem Backup wiederhergestellt werden und in das neue Verzeichnis importiert werden oder die Dateien müssen manuell importiert werden:
- Deaktivieren Sie den CryptoSafeGuard-Schutz für lokale Konfigurationsdateien über BackupAssist Console → Einstellungen → Einstellungen für CryptoSafeGuard → Erweitert

- Stoppen Sie den BackupAssist-Dienst und löschen/benennen Sie den "Jobs"-Ordner im Verzeichnis "C:\ProgramData\BackupAssist vX" um (stellen Sie vorher sicher, dass Sie eine Kopie der x.config-Dateien haben).
- Setzen Sie nun bitte in der Registry den Schlüssel "nextjobkey" unter HKEY_LOCAL_MACHINE\SOFTWARE\BAPersistentData\BAClassicInstallationInfo auf "1".
- Starten Sie BackupAssist und erstellen Sie einen Job (stellen Sie sicher, dass der Job anders eingestellt ist, als der vorherige).
- Klonen Sie diesen Job, bis Sie gleich viele Jobs haben, wie x.config-Dateien in dem vorherigen Jobs Ordner vorhanden waren.
- Schließen Sie die BackupAssist-Konsole, stoppen Sie den BA-Service erneut und ersetzen die neuen x.config-Dateien mit den alten (stellen Sie hierbei sicher, dass Sie die neue CortexIT.BA.BackupJobs.JobService.config-Datei nicht überschreiben).
- Starten Sie BackupAssist erneut und überprüfen Sie, ob die Jobs nun angezeigt werden.
- Reaktivieren Sie nun den Konfigurationsdateien-Schutz wie in Schritt 1.