Disk Cleanup-Skript in Connectwise Automate funktioniert nicht

Disk Cleanup-Skript in Connectwise Automate funktioniert nicht

Lösung


Problem:

Bei der Verwendung des Standardskripts "Disk Cleanup" innerhalb von Connectwise Automate wird das Skript nicht ausgeführt und im Skriptprotokoll erscheint folgende Fehlermeldung:
'Desktop Experience was not detected. Disk Clean requires the Desktop Experience feature on...'

Ursache:

Die Ursache für dieses Problem liegt in der Sprachversion des Servers, auf dem das Skript ausgeführt werden soll. Das Skript überprüft vor der Ausführung, ob das Systemfeature "Desktop Experience" installiert ist. Dieses Feature heißt in der deutschen Sprachversion allerdings "Desktopdarstellung" und wird deshalb nicht von dem Skript erkannt.

Lösung:

Um dieses Problem zu umgehen, empfehlen wir folgenden Workaround:
  1. Zunächst navigieren Sie im Control Center zu Automation → View Scripts. Legen Sie dann Kopien der Skripte "Disk Cleanup" und "Disk Clean Setup" an, um zu verhindern, dass ein Ignite-Patch die bearbeiteten Skripte wieder überschreibt. 
  2. Öffnen Sie die Kopie des Skripts "Disk Clean Setup" und navigieren Sie dort zu Line 30.
  3. Öffnen Sie diesen Eintrag und entfernen Sie die Daten aus dem Feld "Script to Execute".
  4. Fügen Sie in dem Feld "Script to Execute" folgenden Zeile ein:
    (Get-WindowsFeature -name desktop-experience).Installed
    
    
  5. Klicken Sie auf "Save Step" und überprüfen Sie anschließend, ob das bearbeitete Skript nun funktioniert.

Falls Sie bei der Einrichtung des Workarounds noch weitere Unterstützung benötigen oder zusätzliche Fragen haben, können Sie sich gerne an unseren Support wenden.
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