Fix für "BA8012 An unexpected error occurred while starting the CryptoSafeGuard™ shield"

Fix für "BA8012 An unexpected error occurred while starting the CryptoSafeGuard™ shield"

In diesem Artikel finden Sie einen Fix für den Fehler BA8012 in BackupAssist.

Problem:
Der Fehler "BA8012 An unexpected error occurred while starting the CryptoSafeGuard™ shield" kann auf verschiedenen Betriebssystemen auftreten und geht einher mit einer System-Event-Meldung. Gleichzeitig lässt sich der CryptoSafeGuard nicht über die BackupAssist Konsole aktivieren:

Der Dienst "bkpprotector" wurde aufgrund folgenden Fehlers nicht gestartet: 
%%577

und/oder

Anwendungspopup: : \SystemRoot\system32\DRIVERS\bkpprotector.sys failed to load

Beim manuellen Aktivieren des CSG über die Konsole erscheint die Meldung:
Ein Fehler trat bei der Konfiguration von CryptoSafeGuard™ auf.



Ursache:
Die Datei bkpprotector.sys basiert auf einer Windows-Funktion. Sollte das CSG Shield nicht geladen werden können, fehlen entweder Windows-Updates oder die Datei wird von einem Antivirus-Programm blockiert.

Lösung:
Für Windows Server 2008R2 (auch SBS2011) und älter muss das KB3033929 installiert werden [Neustart notwendig].
Sollten Sie den Fehler auch auf anderen OS haben, prüfen Sie bitte die AV-Ausnahmen. Falls das Problem weiterhin besteht, kontaktieren Sie uns bitte direkt über support@elovade.com.
    • Related Articles

    • Was macht der in BackupAssist integrierte CryptoSafeGuard (CSG) ?

      Der in der Backup-Lösung BackupAssist integrierte CryptoSafeGuard (CSG) schützt sowohl bereits gesicherte als auch noch zu sichernde Daten optimal vor Verschlüsselung durch Mal- und Ransomware. Das Tool arbeitet mit Hilfe zweier Technologien: Der ...
    • Was ist die Cyber Black Box von BackupAssist Classic?

      BackupAssist Classic bringt seit Version 11 ein neues Feature im Backup-Segment – die Cyber Black Box. Nach einem Hacking- oder Ransomware-Angriff ist es die Aufgabe von digitalen Forensikern den Ablauf einer Attacke zu rekonstruieren, um ...
    • Notwendige AV Ausnahmen für BackupAssist Classic

      BackupAssist Classic wird häufig durch installierte AV-Systeme gestört, was zu Verzögerungen oder sogar einer Verhinderung des Backups führen kann. Bitte setzen Sie folgende Ausnahmen in den eingesetzten AV Lösungen, um auszuschließen, dass diese ...
    • Windows nach dem Backup mit BackupAssist Classic automatisch herunterfahren

      Mit der Backup-Lösung BackupAssist Classic können Sie Windows 10 nach Fertigstellung eines Backup-Jobs automatisch herunterfahren. Dazu gehen Sie wie folgt vor: Öffnen Sie Ihre BackupAssist Konsole Navigieren Sie zu Verwalten→ Name des gewünschten ...
    • Was unterscheidet BackupAssist ER von BackupAssist Classic?

      BackupAssist Classic und BackupAssist ER haben vom Ansatz her unterschiedliche Konzeptionen: BackupAssist Classic ist die seit vielen Jahren bekannte und bewährte Windows Datensicherungslösung, die über ein modulares Lizenzmodell größtmögliche ...